Payment and Data services are now available

Incident Report for Feezback Status Notification:

Resolved

This incident has been resolved.
Posted Jun 16, 2026 - 06:54 IDT

Monitoring

The incident has been resolved. We will keep monitoring
Posted Jun 15, 2026 - 23:08 IDT

Investigating

We are currently experiencing an unexpected technical issue affecting our financial data and payment services across all banks.

Our team is actively working to restore full service as soon as possible.
We will post updates here as the situation develops.

We apologize for the inconvenience.
Posted Jun 15, 2026 - 16:13 IDT
This incident affected: ASPSP APIs (Discount, Leumi, Yahav, Beinleumi, Hapoalim, Mercantile, Pepper, Mizrahi, Isracard, Max, Cal).